20 - 11 - 2017

Alternative for SVI in Cisco routers - BDI

I had to have some alternative for SVIs used on MLS, but configured on router (CSR1000v). The solution required to have two phsycial interfaces bridge with IP address on top of it. In linux the solution its so trivial, not even worth to talk about doing it via either openvswitch or bridge utils.

The diagram below represents some information about the topology which is going to be configured.

Configure Bridge Domain for VLANs 100 and 200

!
interface bdi 100
encapsulation dot1q 100
ip address 172.20.11.1 255.255.255.240
!
interface bdi 200
encapsulation dot1q 200
ip address 172.20.211.1 255.255.255.240
!

Configured interaces in EVC feature

interface Gi6
service instance 100 Ethernet
encapsulation dot1q 100
bridge-domain 100
!
service instance 200 Ethernet
encapsulation dot1q 200

bridge-domain 200
!
no shutdown
!
interface Gi5
service instance 100 Ethernet
encapsulation dot1q 100
bridge-domain 100
!
service instance 200 Ethernet
encapsulation dot1q 200
bridge-domain 200
!
no shutdown
!

 

I think the most confusing part is when configuring trunk with EVC. The rest of configs it's not complicated.

 
Login Form